v1.90 crashes switching from add support mode back to 3D view

9 Months+ 363

Just installed v1.90 and went about adding in models. had 3 models on the field. Switched to add supports to one model, did so. Then when I switched back to 3d chitubox crashed. Reopened the tried another model added supports, crashed. Did this 3 times and gave up. 


So for now im going back to 1.81 since I never had any problems with it.

New Post (10)
  • Guest 9 Months+
    Quote 2Floor
    v1.90 crashes all the time. Adding support, trying to "quit", going into "settings" - if you look at it wrong the application crashes. It is very very buggy.
  • 9 Months+
    Quote 3Floor
    I'll have to do the same, it's not usable right now.
  • 4 Months+
    Quote 4Floor
    Has this issue been resolved in any way ? It is happening to me now since installing 1.9. The program is unusable.
  • Cliff Knight 4 Months+
    Quote 5Floor
    Very few , if any, v1.9.0 issues have been resolved--it's beginning to look like orphaned software...
  • Li Geng 4 Months+
    Quote 6Floor
    Re-download the program if you download 1.9.0 in the early stage, the program was patched without changing the version number.
  • Cliff Knight 4 Months+
    Quote 7Floor
    That's what "version numbers" are for...
  • Cliff Knight 4 Months+
    Quote 8Floor

    "Re‑download the program if you download 1.9.0 in the early stage, the program was patched without changing the version number."


    I have a copies of the v1.9.0 archives from June 30, 2021 and one i downloaded yesterday (12/23/2021)‑‑they bit‑for‑bit identical (when compared via the Linux "diff' binary file comparison command) The contained files are timestamped 7/24/2021 in both archives, with identical creation times. 

    If this "patch" was not made prior to June 30 then we have observed a remarkable feat, patching an application without changing even one bit of the compiled code, i commend your developers.

    I have seen this stagnation before in applications developed using 3rd party tools, the primary application's developers have no access to the 3rd party code and hence no idea of what it actually does. As the primary app grows in complexity issues in the foreign code become more prevalent until a point is reached at which the primary application becomes unmanageable.

  • 4 Months+
    Quote 9Floor
    I get exactly the same issue (I think)

    if you jump back from 'supports' with anything unsupported on the build-plate  - CB will crash - every bloody time !

    If , however you support all the parts that need it first , THEN add any unsupported parts , it will usually slice OK

  • Cliff Knight 4 Months+
    Quote 10Floor
    The "solution" is to revert to v1.8.x or 1.7.x, I have settled in on 1.7.0 as the added functionality of later versions is minimal for anything i do.
    As to 1.8.1 vs. 1.9.0 it seems to depend on what combination of features and bugs you wish to live with...
  • 4 Months+
    Quote 11Floor
    I am also suffering from this problem. I can't revert back to earlier versions because they don't have the Egloo Mars 3 settings. This is very frustrating. Certainly not going to buy a pro version of the software with so much crashing.