Chitubox 1.9 and Chitubox Pro are both missing the "Drag and drop" features!

Guest 2021-9-28 1003

What happened?  I have pro now and drag and drop is an essential feature of a slicer?  It was working in my older versions of Chitubox, and you would think the pro version would have such a simple thing?  I do high volume printing of the same items over and over and it saves me a ton of heache to place things presupported by dragging my files and dropping them.  This is both STLs and .chitubox files!


Please add this functionaility back!  I noticed others have the same complaint here.

New Post (1)
  • james bryant 2023-2-17
    Quote 2Floor
    I know it's an old post but maybe my experience will help someone else. First of all, I tried every older version and still no drag and drop. No chat room, Elegoo or Chitubox support was able to help. I could be wrong, but it didn't seem like anyone at Elegoo or Chitubox was actually interested in helping. I did find a solution that worked for me and got me building plates and printing again and that was to download Lychee. It worked like a charm straight out of the gate and was very intuitive like Cura for filament printers. Not an ideal solution, I know because I was sincerely hoping that as awesome as my Mars printer was that the software native to it would be equally as stellar. Unfortunately, that one  feature, drag and drop, being missing for whatever reason makes Chitubox essentially useless. Don't get me wrong, I printed fine with it when I did my test files and my first downloaded project files, which already had plates completely built with supports and all. But, when I decided to bring my own stl files into Chitubox it would let me open one file at a time and would not let me add other parts...no matter how I tried. Maybe someone from Chitubox will read this and not ignore this issue. Just glad that I didn't spend $160 on the Pro subscription.