.cfg or plugin that will allow Chitubox 1.9.0 to output .svgx files

Guest 2021-10-5 9418

I have a Flashforge Foto 8.9 resin printer and I see it was added as a printer in Chitubox version 1.9.0.  However, it only wants to create .fdg files on a save and the Flashforge Foto 8.9 requires the saves to be in the .svgx format for them to be printed.


I had a 1.8.1 version set so it would output. .svgx files, but that laptop crashed and I lost that working version.


Can someone assist me in getting a flashforge 8.9 .cfg file or plugin that will allow me to save the output as .svgx files.


Thanks,


James Brett Sloan 

New Post (25)
  • 2021-10-11
    Quote 2Floor
    I am having the same issue....has anyone solved this before?
  • 2021-11-28
    Quote 3Floor
    Not a great work around, but you can change the printer to be one that does export the slice in the correct file type and then copy your settings over.
  • Cliff Knight 2021-11-29
    Quote 4Floor

    In the Flashforge_Foto_8_9.cfg  configuration file, which should be located in the Chitubox application folder in a sub-folder named ../resources/machine,

    change the line that reads:


    defaultSlicerExport:fdg(*.fdg)


    to:


    defaultSlicerExport:FlashDLPrint file(*.svgx), fdg(*.fdg)


    That will allow you to select either at the time you save the sliced file...

  • 2021-12-22
    Quote 5Floor
    How do I do this on a Mac?
  • Cliff Knight 2021-12-22
    Quote 6Floor

    Find the Flashforge_Foto_8_9.cfg  configuration file (there must be some way to search globally for a specific file on a Mac) and edit it as described above...

  • Li Geng 2021-12-22
    Quote 7Floor
    CHITUBOX Pro
    http://manual.chitubox.com/user-manual-pro/requirements#printable-sliced-files
  • 2022-2-1
    Quote 8Floor
    Cliff Knight Find the Flashforge_Foto_8_9.cfg  configuration file (there must be some way to search glob ...
    I am having this same issue. In addition when I try to edit the configuration file it says that I do not have access. Anyone have an answer for this or know a work around or plugin. 
  • Sonja 2022-7-19
    Quote 9Floor
    I am having this same issue. In addition when I try to edit the configuration file it says that I do ...
    So I kind of figured it out, before you go and edit the "defaultSlicerExport:FlashDLPrint file(*.svgx), fdg(*.fdg)" on the Foto 8.9.cfg file first you have to right click and go into properties and there go to the tab labeled security, once there you have to edit the permisions to allow you to change the line within that file.  Once you set all the permissions to allow, apply, hit ok and then open the .cfg file with the notepad in order to change that line and save it.  Now very important, after you do this, you must add the Flashforge 8.9 profile into Chitubox AGAIN in order for the changes to take effect.  If you have any other questions as to how to do this let me know.  Also, this was how I did it for Windows, not sure about Mac as I'm not familiar with them yet.  Long time PC user, not that I hate Mac's they're just too expensive for my budget right now lol.
  • 2022-12-20
    Quote 10Floor
    Hi Sonja and anyone else -  - 
    @sonja trying to understand your instructions
    so if I slice a file it becomes and FDG file (I have flash forge 8.9) 
    if i right click on THAT file  and go to secruity  it shows a bunch of things like system, adminstrators, etc. what specifically do we change? What do you mean by "change the line within that file?"

    Thanks!
  • Guest 2022-12-26
    Quote 11Floor
    Thanks for the info it works for me with Chitubox 1.9.4 basic on Mac and the foto 8.9
  • 2022-12-30
    Quote 12Floor
    I am having the same issue....has anyone solved this before?
    So for those that are MacOS users, what you will do is go into Finder. Scroll down to the Locations section, from here you will find the local storage device (for me it was Macintosh HD). You will click on it and it will bring up the file explorer with a list of directories (folders). You will go to the Applications directory and click into it. From here you will scroll and find Chitubox. Next you will right click on Chitubox, this will bring up a tab with a list of options. You will then need to click "Show package contents". After this it will bring up another tab in the Finder (File explorer on windows). Here you will see a directory (folder) that says "Contents", click into this and find "Resources". Once in the "Resources" directory you will see another directory that says "resource", click into it and find the "machine" directory. Upon clicking into it "resource" it should bring up a list of different machine .cfg files. From here all you need to do is find the FlashForgeFoto8.9.cfg and open it, edit the file by adding the line: defaultSlicerExport:svgx(*.svgx). After doing so you will need to go into Chitubox and add a new printer profile with the updated FLashForgeFoto8.9.cfg file. After this it should be saving the files as .svgx
  • Guest 2022-12-31
    Quote 13Floor
    So I have edited every single version of the Flashforge_Foto_8_9.cfg file I have (in Chitubox Basic 1.9.4 )...
    It STILL refuses to allow me to save a sliced file in .svgx format. Nothing I seem to be able to do allows me to save in this format. 
  • 2023-1-1
    Quote 14Floor
    @ the recent comment user. Did you delete the old printer profile on Chitubox and create a new one? I was having the same problem with it until I deleted the old printer profile I had created and added a new one. 
  • Michael Spurgeon 2023-2-16
    Quote 15Floor
    So I was having a hard time with editing the file as well.  What would happen for me is that I would edit the file in notepad changing the defaultSlicerExport:fdg(*.fdg) to defaultSlicerExport:svgx(*.svgx). Then it wouldn't let me save the file in the folder.  So I saved it to a different folder and then moved the file to the machine folder in the Chitubox program files.  I had to provide Administrator authorization to do that.  However, I was not seeing any changes in the save files.  I tried deleting the machine profile settings and adding the machine again but still only getting the fdg file.  So I ended up deleting Chitubox program completely including all Appdata files and folders (not sure if that part was necessary but it didn't matter in my situation).  Then I reinstalled Chitubox 1.9.4 again from scratch.  Before I opened the program I went in and edited the cfg file with notepad and saved it to a different folder and then moved it to the machine folder (same as above).  Then I started Chitubox and added a new machine.  Then I was able to get the svgx save file.  My Flashforge Foto 9.25 recognized the file and is currently printing it.

    So if anyone else is having that problem (editing the file but not seeing changes) then try to uninstall the program and reinstall it, then edit the file again before opening the program.  Good luck to all.
  • Guest 10 Months+
    Quote 16Floor
    guys i figured it out. save as all models. then make the name of the file and add .svgx. then for type of file save it as all file.
  • 9 Months+
    Quote 17Floor

    I sympathize with any inconvenience you may experience with the Flashforge Foto 8.9 resin printer and the Chitubox software. Try contacting Flashforge directly for support. They may have specific instructions bitlife or resources to help you save the file in the required .svgx format.

  • 8 Months+
    Quote 18Floor


    Are you looking for niche relevant do-follow links? Then you are at right place!
    Yes! its Niche Related Niche blog comments on actual Do-follow pages.

  • 8 Months+
    Quote 19Floor

    Chitubox is a popular software used for preparing 3D models for 3D printing. The .svgx file is commonly used to save your projects mapquest directions and settings in Chitubox. 

  • Guest 8 Months+
    Quote 20Floor

    I've solved it, guys. conserve as all models. then create the file's name and then include.svgx. then save it as a file of type all. pge outage map 

  • 7 Months+
    Quote 21Floor


    Make sure you have the latest version of Chitubox installed. Software updates often include bug fixes and new features, so it's possible that a newer version might have added support for the .svgx format for your printer heic to jpg

  • 7 Months+
    Quote 22Floor

    You'll find dissertation online websites on the web take up residence buy unsurprisingly recognised during the web-sites.Taylor 2048

  • Guest 6 Months+
    Quote 23Floor

    Install the most recent version of Chitubox, please. There's a chance that a more recent version of may now support tunnel rush the because software upgrades frequently bring bug fixes and new features.Printing in svgx format 

  • Guest 6 Months+
    Quote 24Floor

    Chitubox does support various file formats for saving, the specific .svgx io games format you mentioned might require a custom configuration or plugin.

  • Sara Adam 5 Months+
    Quote 25Floor

    If Chitubox version 1.8.1 already works with your printer, you can try to reinstall it Suika game or use another computer to export the .svgx file. 

  • Guest 5 Months+
    Quote 26Floor

    Unblocked school game shell shockers . Want to play Shell Shockers? Try this sport online for free. Make opponents scrambled eggs with Shell Shockers! Shell Shockers unblocked is a fun shooter where you fight an opposition team as a set-off-happy egg.