Flashforge Foto 8.9 unkown file format

4 Months+ 352

I recently got the Flashforge Foto 8.9 printer. I have chitubox 1.9 and selected the correct printer. I know it's supported by 1.9. As a matter of fact I was able to slice and print some exposure test files and attempt on a bust. But then after going to a different USB drive it stopped reading the .fdg file that it slices it to. Oddly even going back to the original USB it won't print those either! I can't find the answer or help anywhere. Does the firmware need to be reflashed? I can't find my printer firmware anywhere. Is there a bug in chitubox or something? I don't understand why it worked before now it is as if it doesn't understand the files. There isn't even a preview picture anymore. If anyone can please help get this sorted I would be very grateful. 

New Post (1)
  • Cliff Knight 4 Months+
    Quote 2Floor
    Asking the obvious, have you rebooted the printer (I'm sure you likely have), tried reloading Chitubox (though that would not explain the original flash drive not working).? Is the flash drive readable in you computer, can you perform a file system integrity check on it? it is common for flash drive file systems to get corrupted when swapped between devices, especially if not properly dismounted (wait for ALL activity to stop before removing it by watching it's activity light, do not trust the computer saying it's OK). My LInux system says it's OK just after clicking "Eject", however the drive's activity indicator will blink for 2-3 seconds after that.

    I take it that sliced files that did at one time print now do not? If not this is likely not a Chitubox issue,but rather a FlashForge problem--have you contacted them?