Supported Versions

M R 4 Months+ 191

Your site says the software supports osx 10.6+, however when I downloaded the program and tried to open it, I got an error saying that it requires osx 10.11+

New Post (1)
  • susanne 4 Months+
    Quote 2Floor
    Same here. Seems we have to update to at least El Capitan to be able to run it.