Can no longer launch program after latest BETA

2020-5-5 2219

I installed the latest BETA version to my PC and I'm now getting an error message when trying to launch the program:

"CHITIBOX.exe - System Error
The Code execution cannot proceed because MSVCP140.dll was not found.  Reinstalling the program may fix this problem"

I press OK 4 times and then nothing is running.  

I tried a few things but I am not getting the program to launch at all now

I tried rolling back one previous BETA version by downloading that file and running the install. 

I tried installing  Visual C++ Redistributable for Visual Studio 2015 

I tried uninstalling all Chitubox progrms listed in Programs and Features and then installing the most recent stable version but I'm still getting the same error message.  

I did have the program installed and working before, I know that 1.6.4.1 was working and I'm pretty sure 1.6.4.2 was installed and working on this PC as well.  

New Post (11)
  • 2020-5-5
    Quote 2Floor
    Actually I just tried this on an other PC and it's working fine, so it looks like it's just an issue with this one PC.  I'll run some further troubleshooting there and see if I can resolve.    
  • Nicolás Herrera 2020-5-5
    Quote 3Floor

    could you pass the mac installer to my email thank you very much! nicodarr8@gmail.com
  • elstonation 2020-5-5
    Quote 4Floor
    I am getting the same issue
  • cbd 2020-5-6
    Quote 5Floor
    There is a visual c ++ 2017 in the installation directory, which can be installed manually
  • 2020-5-8
    Quote 6Floor
    elstonation I am getting the same issue

    I am also getting this same error.  I tried going to the beta and it installs, but it does not open.  

    I am also not able to uninstall past versions of ChiTuBox (I may have deleted them from the program files without going though the uninstall process).  Now I can't do a proper uninstall because the uninstall file is missing.  Could this be the issue?  I don't remember at this point if I deleted these old version before or after I got the missing MSVCP140.dll error


    I also want to note that I tried going back to the stable build and I get the same missing MSVCP140.dll error.  Is the pathing need to be reset?  It seems to be trying to find the dll files in the wrong location, does anyone know how to fix this?


    Update:

    I was able to correctly uninstall the old versions of the sotware by reinstalling them and then finding the uninstall file in the program files folder.  Now they no longer show up in my uninstall window.  I then reinstalled the first the stable and then the beta program and again the missing MSVCP140.dll error persists.  


    Update2: 

    So I tried a adding a new copy of MSVCP140 to my windows file and that causes another error.  I tried solving this other error without success, but in doing so someone mentioned reinstalling visual studio C++


    Finally, I uninstalled my versions of visual studio c++ and reinstalled them and that solved my issue.  

  • Leighton 10 Months+
    Quote 7Floor
    I had the same issue, new install on a new system.

    Easy solution - download a fresh Microsoft Visual C++ Redistributable and install. If the one in your directory is corrupt it's not going to work.
  • 8 Months+
    Quote 8Floor

    Easier fix, go to programs and then find Microsoft Visual C++ 2017 Redistributable there, click on it, hit modify and then repair. There might be multiple based on the system being used, but find the one that matches the system version of Chitubox you downloaded and it should fix it.

  • 6 Months+
    Quote 9Floor
    The easiest solution I found to this problem in windows 10 was to go into add/remove programs, find visual studio c++ redistributable 2017, click on modify and then when it opens the widow you should have the option "repair". For good measure I did this with the 2015 version also . Windows 7 and 8 should have similar options.
    This puts the msvcp140.dll file back into the location the executable is looking for it.
  • Guest 5 Months+
    Quote 10Floor

    That worked!! I had multiple versions of Visual C++ and not every one had the Modify option, but when I went and 'repaired' each one, Chitubox opens for me.

  • 4 Months+
    Quote 11Floor
    The easiest solution I found to this problem in windows 10 was to go into add/remove programs, find ...
    Brilliant. Modify/Repair Microsoft Visual C++ 20XX fixes the missing *.dll file issue quickly and neatly. Thanks for posting this simple but effective solution.
  • 1 Months+
    Quote 12Floor
    Oh my god it worked, thank you so much!