Writing file taking too long

2020-7-31 3649

Since the update my files slice in seconds but when I save the file, it takes over 15 minutes and sometimes longer to save the file.  These are not large complex files, but this is ridiculous.  Is there something I can do to fix this?

New Post (22)
  • cbd 2020-8-3
    Quote 2Floor
    Which version are you using?
  • Guest 2020-8-9
    Quote 3Floor
    Same here, writing often gets "stuck" half way through now. V1.6.5.1 help
  • cbd 2020-8-10
    Quote 4Floor
    Have you tried other versions to slice the project file?
  • Guest 2020-8-14
    Quote 5Floor
    Same here... I actualized Chitubox and it started to happen... :@
  • cbd 2020-8-14
    Quote 6Floor
    Guest Same here, writing often gets "stuck" half way through now. V1.6.5.1 help
    Is there enough memory to use?
  • Guest 2020-8-16
    Quote 7Floor
    Just took over an hour to save a print for the Elegoo Saturn. Thats just from after slicing to when its done writing to the usb stick.
  • 2020-8-21
    Quote 8Floor
    Same here. I have Elegoo Saturn setup. 3 quite complex models. I found removing "volume calculation" makes slicing fast, but writing to file is taking too much time. I mean, 30-40 minutes so far and it is still at maybe 20% visually. I can see file it is writing to is growing slowly. so it has not stuck. But seriously - this is a bit too much. I've measured. It is writing ~1.6MB per minute. 
    Another detail - all three models have tons of build-in supports that I generated in Prusa Slicer.
  • Guest 2020-8-22
    Quote 9Floor
    Another Elegoo Saturn here. Taking ages to slice if you want the volume estimate and then saving the file is taking over an hour to write to usb after slicing. I also tried saving to an SSD to see if that would help but got similar results.
  • 2020-9-15
    Quote 10Floor

    Same here - slicing is fast (esp after turning off volume calc). But writing is taking way too long. Almost an hr now.......

    Just got my Elegoo Saturn and trying to do a test print

  • cbd 2020-9-16
    Quote 11Floor
    Have you used the gray level and image blur function turned on?
  • 2020-9-17
    Quote 12Floor
    Yes, they were on by default for Saturn. Grey 3/ Image blur 2
  • Guest 2020-9-27
    Quote 13Floor

    Same.
    Unable to save job file.
    Progress bar make many hours to advance. (i have stop before dying from olding)

    PLEASE HELP US !

    Version 1.6.5.1
    Mesh polygon count: 200 000 poly
    RAM: 12go, SSD, Intel i7, GTX 1080, etc...
    What's the problem?
    I have installed MeshMixer. can this cause conflicts?

    is there any alternative software ?

  • cbd 2020-9-27
    Quote 14Floor
    We have optimized the slice saving.
    Please ask if you enable features such as AA and image blurring.
  • Guest 2020-9-27
    Quote 15Floor
    We have optimized the slice saving. Please ask if you enable features such as AA and image blurring ...

    is not a slicing issue. (for me) Slicing is ultra fast without bulk computation.
    But writing job file to ssd take very long time. Yesterday, my file have taking +5h to save a 220mo file. (.lgs30 file)

  • Guest 2020-9-28
    Quote 16Floor
    Also having this issue on 1.6.5.1
  • Tim Richter 2020-9-30
    Quote 17Floor
    Same issue on 1.6.5.1 using AA Grey level 3 and Image Blur Pixel 3. Slices pretty quick, writing regardless to which device takes a LONG time. Sometimes it appears to improve after a reboot of workstation. This has only started wtih 1.6.5.1 for me and Using the Saturn. I've never had this type of issue in the past with Photon.
  • Sergei 11 Months+
    Quote 18Floor
    Same issue on 1.7.0 and 1.6.x versions
  • Guest 11 Months+
    Quote 19Floor
    same here with 1.7.0 and 1.6.x versions. Slicing can be done quickly but writing the ctb is very slow. I thought it might be writing to a slow USB stick but now I've tried it to the main SSD on my computer and it still takes 10-15 minutes for a ctb file that ended up being ~350MB.
  • 11 Months+
    Quote 20Floor
    Which version are you using?
    It's the same here with version v1.7 it take around 40 minutes to save anything for mars 2 pro so not as big as the Saturn but still!! That's is way too long !! Please fix this we lost way to much time with that !
  • cbd 11 Months+
    Quote 21Floor
    It's the same here with version v1.7 it take around 40 minutes to save anything for mars 2 pro so no ...
    It's already being optimized.
  • Majestic Miniatures 10 Months+
    Quote 22Floor
    I found a work-around which solved the slow export / saving issue for me.

    In my experience, some of the machine definitions have a problem which causes the export to be very slow (up to 5 hours at a time). My issue was with the Epax X1K. When I use the X1K default machine definition which is shipped with CHITUBOX, it takes hours and hours to export. I ended up using a the Epax X1 definition which is a very similar printer and then modified the resolution and other settings to match the X1K. This worked beautifully. The export was very quick again and my print came out perfect.

    Try using a similar machine and then update it with the particular resolution and settings of the printer you are using.
  • 27 Days+
    Quote 23Floor
    I just tried something similar by just adding a second copy of my actual model of printer (Epax e10) and then slicing/saving and that seemed to work as well!  I did make 1 change to the default resolution, then changed back to what it should be.  Thanks for the inspiration!  v1.9.0 btw