Chitubox Slicer is VERY VERY broken [EDIT - it's "network send"]

2020-11-9 2883

[EDIT] - it's the "network send" feature - it corrupts files, see next reply/post from me on this topic for details. Elegoo, seriously, you couldn't figure out how to safely copy files over ethernet? 



Randomly the slicer will go completely haywire - take slices out of the model, mirror them, and put them on the opposite side of the build plate. At the same time it generates rectangles that cover the entire build plate. See the image above. The worst part is, it's random,  sometimes the slicer generates a valid print like this one 


, and sometimes with the exact same settings, it makes slices like in the image.


This ruins prints. It also ruins FEPs and after only a week with my Saturn, it has already damaged my screen. The broken slices with the giant rectangles ripped parts off their supports which where then crushed against the FEP and screen by the parts that were still attached to the build plate.


When the slicer fails like this, it doesn't show in the 3D preview. In order to see broken slices, you have to save the slice file, and then re-import it.


Here is the file that was used to create the broken slice file in the image above: https://drive.google.com/file/d/1Ihm5V-KCZwPV71EnpNS-BWOKd-wMu1Ev/view?usp=sharing


I only recently figured this issue out - but already I can say it's happening a lot - all 3 of my most recent prints with completely different files have this issue.

New Post (12)
  • cbd 2020-11-10
    Quote 2Floor
    Yes, your slice file in the first picture is broken. Are both slices the result of slicing the project file?

    Please re-add the slice of this model to see if the problem still occurs.
  • cbd 2020-11-10
    Quote 3Floor



  • cbd 2020-11-10
    Quote 4Floor
    Three tries and no problems.
  • 2020-11-11
    Quote 5Floor


    The problem is the network send function - I tested this by opening a large known good ctb file in Chitubox and confirming that the slices look ok, like this:


    Then I used "network send" to send it to the printer - but I aborted the print, removed the flash drive, and opened the version of the ctp file on the flash driver in Chitubox to check it,

    and, 

    it looks like this:


    One other thing - on the Saturn's little screen - the file looks fine - there's no hint of the heinous mess 


    WTF Chitu! - sending files over a network is a solved problem - there are libraries for that that have been stable for decades - don't tell me you've been writing low-level network code? 


  • cbd 2020-11-20
    Quote 6Floor
    Your image does not preview, can I re-upload it?
  • 2020-12-6
    Quote 7Floor
    I can confirm this bug.  I tested Network Send on 1.6.5, 1.6.5.1, and 1.7.   Sending through a stock comcast modem to an Epax X1-DJ.  I eliminated all hardware causes with Epax's excellent customer support (multiple printers, screens, and mainboards).  I can recreate the issue by slicing with any of those versions of Chitubox, then Network Send to printer.  If you print the file, the preview looks fine on the printer.   It didn't hurt my printer other than ageing the screen unnecessarily (unlike the OP), but did create big 'flaps' of resin off the model.  I've photographed the print screen during numerous dry prints, as well; it matches what the OP is showing.  If you take the USB back to the computer, and open the *.ctb file, you can see the problem layers in the preview.  I can work with you on identifying the problem.  Let me know what you need.
  • 2020-12-7
    Quote 8Floor
    I should add, I didn't have a problem until mid-October, soon after I installed 1.7 (I did not uninstall the previous versions).
  • Leto Atreides 2020-12-8
    Quote 9Floor
    Just a bit of clarification for the OP, Chitubox is not developed by Elegoo.  Its just one of (two?) slicers that can generate files for the Elegoo machines.
  • 2021-1-25
    Quote 10Floor

    This issue is still there in 1.8.0 and is a complete disaster!!!

    Attached are a local saved file and a version sent to the printer with Network Sending.

    Open each file in Chitubox and you can see the good version and the corrupt version (layer 11 is bad).

    Random layes get corrupted in all sorts of strange ways, from filled regions to missing regions.

    My printer is an Epax E10.

    DO NOT USE NETWORK SEND. It is completely broken.


    上传的附件:
  • cbd 2021-1-26
    Quote 11Floor
    We have tested and did not appear, we will continue to test.
  • Guest 2021-7-1
    Quote 12Floor

    I was facing the same situation while using the "Network Sending" function. 

    I have tried all software versions from 1.6 to 1.8.1 and even the Pro version. I tried two different printers, Elegoo Saturn and SainSmart KL9. Same issue in all cases!

    After uncountable wasted hours with both companies` terrible support, I decided to troubleshoot it myself and ... I have found the solution!!

    The problem:

    The flash drive writing speed is too fast for the cheap hardware used on these printers.

    The fix:

    Use the cheapest flash drive you can possible find, with the worst writing speed possibly.

    The flashdrive must be 16GB (--> 14.9GB capacity <--), formatted using FAT32 and 8Kb allocation unit size. 

    I have tried many other flashdrives (from 4GB to 64GB), including 16GB flashdrives with different capacities (14.4GB, 14.3GB, 14.7GB) but the ONLY specs that worked is the one listed above.

    Right now I have 3 printers running via network without any issues.


    Side notes:

    - Make sure the printer is getting a valid IP address for your network. I have seen the printer getting an invalid IP address multiple times.

    - Make sure your antivirus/firewall is not blocking Chitubox.

    - SainSmart KL9 has a blue USB port, normally used to indicate USB 3.0 compatibility. However, it does not read 3.0 USB flashdrive.

  • 6 Months+
    Quote 13Floor

    Seen this myself today, Chitubox V1.9.1, Elegoo Saturn with latest firmware (4.4.3).
    I had changed the SD card to a 32Gbyte one, not for capacity reasons but simply beacuse it's low profile and doesn't protrude as much as the supplied stick.
    So the first print with the new stick, sent over the network from Chitubox, looked fine on the printer display and so I started the print.
    Noticed at some point that there appeared to be a 'skin' in the resin, it's old resin a year past its 'best before' date. I initially blamed the resin but it had worked fine with a different print last week.
    So I thought I would reload the file into Chitubox, where I saw that the 'skin' was in fact multiple layers currupted within the model, a mix of large rectangles or layers with lots of groups of small rectangles. Oddly the file size was identical for both the version created on the PC and the version sent to the printer. Had I continued to print that model it would have been disastrous.
    Having worked out that the file was corrupted I came across this thread, the idea that it doesn't happen with the supplied USB stick doesn't give me enough confidence to trust the 'send over network' option, and if I then go to the effort of checking the file by reloading into Chitubox by plugging the stick into the PC, well that defeats the object of the network transfer.