1.8.0 runs very slow and uses 100% CPU

Randy 10 Months+ 2294

I am seeing poor performance with 1.8.0.  Even when it is just sitting there it spikes up the CPU usage to 100% and when you try to do anything like open a stl file or start slicing it takes several seconds before it start to do anything.  Overall it uses a lot more CPU and runs much slower then 1.7.0 so much so I have had to go back to 1.7.0.

New Post (19)
  • Dustin Kelley 10 Months+
    Quote 2Floor
    it would be helpful to know what your system specs were. Ram, processor, etc...
  • Randy 10 Months+
    Quote 3Floor
    I have a I7-9750H CPU, SSD and 32GB of memory
  • cbd 10 Months+
    Quote 4Floor
    hello.
    Currently the slices are saved using multi-core slices, so they take up a lot of memory. Processing is slow at the beginning, but in the latter part it is quite fast, and in general much faster than 1.7.0.
  • Randy 10 Months+
    Quote 5Floor
    Don't get the me wrong the new features are great but in my experience so far, slicing is about the same perhaps a little faster but other areas like saving files, launching Chitubox and even just trying to shut down are noticeably slower.  For example I timed saving typical file and with 1.7.0 and it took 11 seconds and with 1.8.0 the same object took 18 seconds.  It just doesn't feel as nimble as 1.7.0
    If there are some logs or anything I can do to help I would be happy to.
  • cbd 10 Months+
    Quote 6Floor
    Randy Don't get the me wrong the new features are great but in my experience so far, slicing is about the ...
    Thanks for your feedback, we will test
  • 9 Months+
    Quote 7Floor
    I have found the same thing.  Performance was so poor on my laptop, an ASUS Rog laptop with 32 gig ram, that it messed up the entire system and I had to do a reinstall.  I did not reinstall 1.8.1.  

    On the other machine I use, a Microsoft Surface laptop with 32 gig, I would estimate for all actions 1.8.1 is 5 times slower than 1.7.1.  As the original poster stated, it's particularly noticeable trying to exit the program.  With a relatively complex model loaded, the time from pressing Close on the window until I see the "are you sure you want to exit" dialog is 4 seconds, for example just now, and that's with nothing else running on the system.   If I had 3 models open, which wouldn't be uncommon in my usual way of working, the whole machine would be at a crawl, and I would estimate it would be something like 15 seconds.  
  • cbd 9 Months+
    Quote 8Floor
    I have found the same thing. Performance was so poor on my laptop, an ASUS Rog laptop with 32 gig r ...
    What is the size of the three files?
  • 9 Months+
    Quote 9Floor
    I've found the same.  I moved to 1.8.1 in hopes that saving file times would improve, but it has not and slicing has become slow as well.  I'm moving back to 1.7.0 and will look into prusa or lycee unfortunately
  • Guest 9 Months+
    Quote 10Floor
    Hello
    I also have a problem with a very slow start of version 1.8 and a CPU load after start this version even without a loaded model. It's not 100%, but it's a lot.
    i3-3110M
    PS: please create 3 different icons for .stl / .chitubox / .photon files. It will be improve tidiness in the directory 
  • Guest 7 Months+
    Quote 11Floor
    I don't know way I use 1.65 to Slice and save is very fast , but update to 1.7 , the Slice is fast is ok , but Save is slow , some time is over 5 hours  , from 1.81 Slice is also stop in about 20% , I don't know way and how can I do , now I just use in 1.6.5, can not update , I use the Intel Xeon W 3.2GHz and 32 GB DDR ram and Redeon Pro Vega 56 8GB , is iMac Pro , I think is not the problems with Mac , because I see only use about 10% the CPU and Ram, just not Run ? how can I use the 1.8.1 , or 1.7 , because I watch the Slice , the 1.7 is better than 1.6.5 very much . thanks 
  • Guest 7 Months+
    Quote 12Floor

    Have the same problem with Chitubox (currently 1.8.1) becoming so slow that I either have to go back to an old version or switch to another application. It's overall terrible slow and it did use to be so fast.  Why? The overall slow speed don't seem to be terribly dependent on the loaded model but just to give some examples. I currently have 6 models loaded with a total sum of about 6000 vertices and being about 6, 6, 6mm each in size, so not many layers high. If I click the menu button it takes around 25 seconds before menu appears and the same for it to be removed when clickin outside. Trying later after saving a file to disk the menu operation is suddenly fast and responsive for some reason. Opened scale. Clicked percent Y field and waited for it to get selected and get the cursor. Then clicked percent Z and it took 25 seconds until the selection moved to that field. It's driving me nuts.  Running on i7-5820K, 32Gb and RTX 2070 Super.


    Edit:

    Tried same things in 1.7.0 and responce time is zero when doing the same operations.

  • Guest 3 Months+
    Quote 13Floor
    Just downloaded 1.9 hoping the lagging issues from 1.8 would be fixed. It got worse, 1.9 barely runs! I'm going to Lychee, get it together.
  • Randy 3 Months+
    Quote 14Floor
    I am having the same problem, it is excruciatingly slow.
    Please fix this
  • Guest 2 Months+
    Quote 15Floor
    Unusable for me. Running I9, 128GB Ram, GeForce 2080Ti, SSD - Same issue
  • David McDermott 1 Months+
    Quote 16Floor
    I'm having the same problem. I'm running Windows 11 on an AMD Ryzen 7 3700X with 64GB or RAM and an AMD Radeon 5700XT video card.
    I installed Chitubox 1.9, and it was so laggy as to be unusable. This doesn't have anything to do with where slices are stored--even opening the menu to import a file took forever, BEFORE anything was sliced.
    Looking at several posts and videos online, I tried disabling Touch Keyboard and Handwriting Panel Service," but that had no effect. Finally, after reading this thread, I uninstalled 1.9 and installed 1.7. Version 1.7 works wonderfully! It looks like something was done to the basic UI between those versions which conflicts in a major way with certain Windows installations.

    I hope you can figure this out. I'd like to be able to use all the features of 1.9. Who knows, I might even be persuaded to go Pro.
  • Guest 15 Days+
    Quote 17Floor
    Same here, on both 1.8 and 1.9. All the time, the UI will lock up for 10-15 seconds and then start to work again. It does it if I switch between apps, it happens when I open dialog boxes, pull down menus, quit the program, etc. Other functions, like rotating the display, moving and rotating the models, etc. work great. When it is in its locked up state the CPU hits 100% on that CPU core, then drops down to a few percent again when the app unlocks. It makes the software so frustrating to use, it's unbearable. I didn't have this problem until recently, but I am not sure what triggered the change.

    Those of us that are having these issues, do we have something in common? Something unusual maybe? For example, I am running large dual monitors, and have a laptop with an Intel HD and nVidia GTX 960 (in an external enclosure). Other specs are: Win 10 Pro, Lenovo Thinkpad X1 Yoga, i5-10210U, 16GB Ram, 500GB SSD, etc.
  • 12 Days+
    Quote 18Floor

    I7-90 64G内存2070s显卡,启动V1.9软件后,电脑会假死状态,之前win10系统用的挺流畅的,但在前天系统升级到win11后,就这样了,希望得到修复。

  • Guest 12 Hours+
    Quote 19Floor
    Same problem after updating to windows 11 on 1.9.  Was working fine on windows 10. but after upgrading to windows 11, chitubox is verrry laggy when trying to open a file or click on any of the options, like scale, or slice, or save.  Takes about 10-20 seconds before it responds. 
  • Guest 12 Hours+
    Quote 20Floor
    Uninstall 1.9 and re-installed it and that seems to have fixed the laggy problem on windows 11.