CHITUBOX v1.9 .ctb not reading on Elegoo Mars 2P

2 Days+ 308

I upgraded to 1.9 today and attempted to print some miniatures. After slicing and placing the file on the USB drive my Elegoo Mars 2P didnt recognise the file and read it as an invalid folder even though the file was a .CTB. I uninstalled 1.9 and reinstalled 1.8 Beta did exactly the same and the printer is working perfectly fine. FYI if anyone else is having the same issue. 

New Post (14)
  • Guest 2 Days+
    Quote 2Floor
    i have the same problem with my Saturn after update Chitubox...
  • 2 Days+
    Quote 3Floor
    same issue here on a creality Ld002R
  • Guest 2 Days+
    Quote 4Floor
    I just purchased the pro version of chitubox and my saturn cannot read any of the files. 
  • 2 Days+
    Quote 5Floor
    Guest I just purchased the pro version of chitubox and my saturn cannot read any of the files.
    Was this on 1.9? Try using 1.8 as it worked for me. Crazy to think that version 1.9 was released when printers cant even read the files it generates.  
  • Guest 2 Days+
    Quote 6Floor
    Pro is like version 1.1 or something, they don't follow the same version numbers as it's completely different software. I was shocked at how different it is 

    But either way, they clearly updated something common across both for file saving that broke and they never tested it
  • 2 Days+
    Quote 7Floor
    Same for me, i have a Elegoo mars 2 and i try on chitubox profree trial , and chitubox basic too, my printer is unable to read ctb files .
  • Guest 2 Days+
    Quote 8Floor
    same for me. not read
  • 2 Days+
    Quote 9Floor
    I had the same problem with my Phrozen Sonic Mini 4K. Please try updating the firmware. I downloaded on chitubox.com somewhere but cannot find it now.
  • Guest 2 Days+
    Quote 10Floor
    Same here, print file from 1.9.0 with Saturn (14.24, PJ L Screen firmware) printer reports invalid print file.  It prints a file I had from 1.8.1 on 14.24 firmware fine still.
  • Guest 1 Days+
    Quote 11Floor
    So I updates my mars pro 2 and I'm able to print now. My Saturn however appears to be bricked after the firmware
  • 1 Days+
    Quote 12Floor
    Yes I have the same problem does anyone know a fix?
  • FlashBackJack 1 Days+
    Quote 13Floor
    Same here LD-002H   1.9 not recognising any files 
    may i suggest to the support team they fix this ASAP 

    if you want my money for Pro  this is not the way to get it 

    The fix is   Uninstall 1.9 because it does not work right 
    re install 1.8 
  • Guest 1 Days+
    Quote 14Floor
    Me too with Creality LD-002H. 
    The only fix is reinstall V 1.8.1
  • Guest 1 Days+
    Quote 15Floor
    So, it does state that you require a new firmware, for the Mars2Pro V4.4.3.
    My problem is, I downloaded the firmware and it is still showing the 4.3.13 in the info display.... Haven't even attempted to use CBox 1.9 yet.
    (I just received the printer and only did the rook test print using V1.6 so far).