./CHITUBOX: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.15' not found (required by ./CHITUBOX)

12 Days+ 88

cat /etc/issue

Linux Mint 20 Ulyana \n \l

uname -a

Linux atit2 5.4.0-65-generic #73-Ubuntu SMP Mon Jan 18 17:25:17 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

Looks like there is no install for QT5.15 on linux mint 20 so I cannot start CHITUBOX

What can I do ? 

using CHITUBOX V1.8.1

New Post (2)
  • 12 Days+
    Quote 2Floor
    fixed that by creating a script to run with included libs

    cat runchitu.sh 
    export LD_LIBRARY_PATH=`pwd`:$LD_LIBRARY_PATH
    ./CHITUBOX

    but now it crashes because of this
    =======Version: "120" valid: true
    QOpenGLShader::compile(Vertex): 0:2(12): error: extension `GL_EXT_gpu_shader4' unsupported in vertex shader

    *** Problematic Vertex shader source code ***
    #version 120
    #define lowp
    #define mediump
    #define highp
    #line 1
    #extension GL_EXT_gpu_shader4:require
    void main(){}
    ***
    ==bSupport_GL_EXT: false
               GPU vendor: Intel Open Source Technology Center
               GPU version: 2.1 Mesa 20.2.6
               GPU render: Mesa DRI Intel(R) HD Graphics (ILK)
               core: false
               validVersion: "21"
               hasFrameBufferObjects: true
    QOpenGLFramebufferObject: Framebuffer incomplete attachment.
    QOpenGLFramebufferObject: Framebuffer incomplete attachment.
    QOpenGLFramebufferObject: Framebuffer incomplete attachment.
    QOpenGLFramebufferObject: Framebuffer incomplete attachment.
    QOpenGLFramebufferObject: Framebuffer incomplete, missing attachment.
    save to file: "/home/michael/.config/ChiTuBox/global.cfg"
    save to file: "/home/michael/.config/ChiTuBox/machine/1.cfg"
    save to file: "/home/michael/.config/ChiTuBox/machineBackup/1.cfg"
  • Guest 11 Hours+
    Quote 3Floor

    Hello,

    Ubuntu 20.04 here and suffering the same issue. QT 5.15 is not widely accepted within all distributions - and for a normal user its harder to get it.
    The Chitubox 1.8.1 for Linux contained a lib directory, so the Question is how chitubox can be started with its internal lib?
    As far as trying to make it work, I tried your script, but honestly dont understand how this Path is changing for the internal lib directory?

    Another solution I tried was to download the QT 5.15.2 Source code, and qmake, make and make install it.
    Download QT 5.15. Source Files here: https://www.qt.io/offline-installers
    Here is some Wiki of the qmake/make/make install https://doc.qt.io/qt-5.15/configure-options.html

    I now stuck with the make install command:
    "Error copying /home/XXX/Programs/chitubox/CHITUBOX V1.8.1/qtdeclarative/src/qmlmodels/plugins.qmltypes to /opt/qt5_15/qml/QtQml/Models.2/plugins.qmltypes: Cannot open /home/XXX/Programs/chitubox/CHITUBOX V1.8.1/qtdeclarative/src/qmlmodels/plugins.qmltypes for input
    make[3]: *** [Makefile:15810: install_do_install_qmltypes] Error 3
    make[3]: Leaving directory '/home/XXX/Programs/chitubox/CHITUBOX V1.8.1/qtdeclarative/src/qmlmodels'
    make[2]: *** [Makefile:169: sub-qmlmodels-install_subtargets-ordered] Error 2
    make[2]: Leaving directory '/home/XXX/Programs/chitubox/CHITUBOX V1.8.1/qtdeclarative/src'
    make[1]: *** [Makefile:62: sub-src-install_subtargets] Error 2
    make[1]: Leaving directory '/homelXXX/Programs/chitubox/CHITUBOX V1.8.1/qtdeclarative'
    make: *** [Makefile:352: module-qtdeclarative-install_subtargets] Error "

    I dont even understand why make install of QT needs to modify chitubox. But neither the "error prompted" modified Chitubox works now,
    nor the second test of a new extracted chitubox copy:
    I get the pretty easy error prompted that QT_5.15 is still missing on the system, and its true, the QT make install didnt seem refresehed the so.5 file or added any so.15 file:
    "./CHITUBOX: /lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.15' not found (required by ./CHITUBOX)"

    Long story short: @Chitubox devs, I dont want to get into compiling and installing my own QT Developer Suit with 3GB if size! Just make chitubox working on its own dependencies, and update the wiki so everyone knows how to start chitubox with such parameters by CLI.

    Thanks


    EDIT:

    Thanks to another thread in the Forum I found a solution to start CHITUBOX with its included QT5_15.

    I created a file and edited the paths to fit my paths. The first path has to go into the "included lib directorie" and the second path has to point for the executable CHITUBOX file, or AppRun file if you desire.

    Just execute the script and it starts CHITUBOX with the LD_LIBRARY_PATH set to the internals.


    # --- begin ---
    #! /bin/bash
    export LD_LIBRARY_PATH=~/Downloads/Programs/chitubox/1.8.1/unmodified/lib/:$LD_LIBRARY_PATH
    ~/Downloads/Programs/chitubox/1.8.1/unmodified/CHITUBOX
    # --- end ---


    Here the other threads:

    https://forum.chitubox.com/?thread-800.htm